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Documentation Feedback
Your feedback helps us keep our documentation up-to-date and accurate. If you have any comments, you can email 
us.

Please include the following information:

• Product name and version number (if applicable)
• Manual page number
• Your comment

Send email messages to:

FireSystems.TechPubs@honeywell.com

Please note this email address is for documentation feedback only. If you have any technical issues, please contact 
Technical Services.
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Section 1 About This Manual

1.1  Manual Conventions

1.1.1  Notes, Cautions, and Warnings
This manual contains notes, cautions, and warnings to alert the reader as follows:   

1.1.2  Procedures

Example Text: Main Menu select File >Print >Events.

The graphic above is represented in the Example Text.  All selections, fields, buttons, and 
screen titles are spelled (upper/lower case) exactly as the appear on the display.

1.1.3  Referencing Other Documents
Example: Refer to the ONYXWorks™ Workstation manual.

italic text is used to reference a document by its specific name.

NOTE: In this document, unless expressly written otherwise, when the term ONYXWorks™ 
Workstation or Workstation is used those terms refer to the software application and the computer 
it is installed on as one.

NOTE: Supplemental information for a topic, such as tips and references.  

! CAUTION: Summary in bold
Information about procedures that could cause programming errors, runtime errors, or equipment 
damage.

!
WARNING: Summary in bold
Indicates information about procedures that could cause irreversible equipment damage, irreversible 
loss of programming data or personal injury.
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About This Manual Related Documentation
1.2  Related Documentation
The following is a list of documentation resources related to the ONYXWorks™ system.

• ONYXWorks™ Echelon Gateway (P/N 52305)
• ONYXWorks™ NFN GW Embedded (P/N 52306)
• ONYXWorks™ NFN GW PC (P/N 52307)
• ONYXWorks™ Receivers Gateway (P/N 52308)
• ONYXWorks™ Routers-Repeaters (P/N 52327)
• ONYXWorks™ Workstation Manual (P/N 52342)

NOTE: The contents of this manual are important and must be kept in close proximity of the 
Workstation.  If building ownership is changed, this manual including all other testing and 
maintenance information must also be passed to the current owner of the facility.  A copy of this 
manual was shipped with the equipment and is also available from the manufacturer.
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Section 2 Configuration Tool Usage Preparation

2.1  About the Configuration Tool
The Configuration Tool is used to customize ONYXWorks™ Workstation’s graphical user 
interface (GUI) to display your building’s facilities monitoring system.  An authorized event 
responder will use your customized GUI to identify the location of and respond to an event that 
Workstation annunciates.

After modifying a Workstation GUI design with the Configuration Tool verify it is displayed on the 
Workstation correctly.

2.2  Section Overview
These are the Configuration Tool tasks that are done before you are modify the system’s database.

• “Configuration Tool Installation” on page 8.
• “Configuration Tool Operation Descriptions” on page 9
• “ONYXWorks™ System Database Background Creation” on page 10.

.

NOTE: All procedures are written with the assumption that your PC mouse clicking operations 
use default settings for left and right mouse clicks.
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Configuration Tool Usage Preparation Configuration Tool Installation
2.3  Configuration Tool Installation
The Configuration PC that the Configuration Tool will be installed on should meet the following 
requirements.

• Intel Pentium Processor.
• Windows® 2000 or XP.
• VGA Display Card.
• 1280 x 1024 is the recommended setting for screen resolution.
• CD-ROM Drive.
• 1.0 GHz CPU.
• 512 MB of RAM.
• 5 MB of free hard-disk space.

2.3.1  Configuration Tool Installation Procedure
Step 1. Insert the CD-ROM in the Configuration PC’s CD-ROM drive.

If the CD-ROM does NOT automatically start, use Windows Explorer to locate and start 
this file: (your CD-ROM Drive letter):\Setup.exe.

Step 2. Perform the on-screen prompts.
Step 3. Remove the CD-ROM.

Rebooting your PC is not required to start using the Configuration Tool.

NOTE: A Configuration PC is defined as a PC that has the Configuration Tool installed on it but 
is it not monitoring a life safety system.

NOTE: You may want to change the resolution of your Configuration PC display settings to 1024 
x 768 pixels to match the Workstation’s display setting.
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Configuration Tool Operation Descriptions Configuration Tool Usage Preparation
2.4  Configuration Tool Operation Descriptions
Review this information because the procedure throughout this manual will be written assuming 
you understand the concepts about operating this software application that is provided here.

2.4.1  About Starting the Configuration Tool
The installation program has added an entry for the Configuration Tool (Windows >Start 
>Programs >Facilities Monitoring >Configuration Tool).

2.4.2  About Importing a Database to Edit

Figure 2.1  Configuration Tool Initial Launch Screen

Use System Data Icon Selection
Only use this function to open and edit the database already resides on the Configuration PC.  Refer 
to “Database Modifications Procedures” on page 11 for more information.

Locate Database to Edit Icon Selection
Only use this function to open a database that reside some place other than the one that currently 
resides on the Configuration PC.  Refer to “Database Modifications Procedures” on page 11 for 
more information.

2.4.3  About Exiting the Configuration Tool
Exiting is linked with saving in the Configuration Tool when it is running on a Workstation that is 
monitoring your ONYXWorks™ system.  The tool always requires you to exit the application and 
then respond to the Save changes prompt with a:

• Click on the Yes button to update the database the Workstation will use.
• Click on the No button to NOT update the database the Workstation will use and discard the 

changes.

About Configuration Tool Main Window Icons
After clicking on its respective icon usually a window displays that has a main menu at the top of 
the window.  Those main menu selection display a list of choices which when selected display a 
window where you will enter information.  After entering information into the window’s fields; all 
function require a click the OK button to save the changes or the Cancel button to discard the 
information.
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Configuration Tool Usage Preparation ONYXWorks™ System Database Background Creation
2.5  ONYXWorks™ System Database Background Creation
It is highly recommended that you create graphic background drawings (i.e. floor plans displayed 
as a background for a system screen) before you start creating the system design with the 
Configuration Tool.  Refer to “Screen Title and Background Additions Procedure” on page 15.

You will need a graphic editing program for creating and or resizing the graphics backgrounds.  
Use the Configuration Tool to add the raster or vector files that you created or modified using your 
graphic software application.  The better the resolution of the background in the Configuration Tool 
the better the resolution on Workstation.

The supported graphic formats that can be added as a background are these vector and raster file 
formats.

Vector Files
Enhanced Metafile Format (EMF) and Windows® Meta Files (.WMF) file types can be imported 
into the Configuration Tool.  Those file types typically degrades less in visual display quality than a 
raster file.

Raster Files
Bit Map (BMP), Graphic Image Format (GIF), and Joint Photographic Experts (JPG) files types 
can be imported into the Configuration Tool.  However those files types degrade more in visual 
display quality than a raster file, especially when the Workstation’s zoom functionality.

NOTE: The graphic file that will be imported can NOT have a Read Only attribute.
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Section 3 ONYXWorks™ System Database 
Modification

3.1  About Database Modification
These steps are a suggested method to organize your facilities monitoring system database into a 
design that will be displayed on a Workstation using the Configuration Tool.  Some steps can be 
performed before others, so their order is not always implicit to completing your new system 
design.

A gateway’s node and the node’s points can be manually added and defined with the Configuration 
Tool, however it is highly recommended that the auto-creating method be used instead.  This 
procedure information is based on the assumption a system monitoring Workstation database was 
created using an auto-creation process on a Workstation that was monitoring your ONYXWorks™ 
system.  Refer to Workstation manual or “About Database Creation” on page 10 for more 
information.

NOTE: Please familiarized yourself with “Configuration Tool Usage Preparation” on page 7 
before you start these procedures.
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ONYXWorks™ System Database Modification About Database Modification
3.1.1  About Database Creation

A Workstation should be added to the system by the Admin User.  For the purposes of this manual, 
it is assumed that the database that will be modified in Configuration Tool was achieved using the 
procedures in the Workstation manual.  Refer to the Workstation manual for more information on 
these subjects:

About Adding an Existing Gateway
When the Workstation is first started, an Admin User can connect gateways that are physically 
connected or available through your ONYXWorks™ system using Network Configuration 
operation selected in the Configuration Tool.

About Adding a New Network Connection
The Admin User creates a Network name and then adds a gateway.  Network Names and gateway 
connections are created using the Configuration Tool.

About Auto-Creating Node and Points on the Gateway
A gateway’s nodes and the node’s points can be manually added and defined with the 
Configuration Tool, however it is highly recommended that the auto-creating method be used 
instead.  The auto-creating method captures the node’s exact point ID.  It is highly recommended 
that the database be modified offline and although online modification is possible, the database not 
be modified while the Workstation is monitoring the ONYXWorks™ system.

There are differences between auto-creating points on a new system versus adding new points to an 
existing system. 

New System Point Auto-Creation  Start by configuring gateways with a monitoring 
Workstation’s version of Configuration Tool.  After the gateway is configured exit the 
Configuration Tool and then save the database.  At this time send events for all points on the 
associated gateway(s) and the Workstation will automatically create points and populate screens 
with icons.  Once the all events for all points have been sent complete, the database can be 
modified (refer to “Database Modifications Procedures” on page 11).

Existing System Point Auto-Creation  If only a few new points need to be added to an 
existing system start the monitoring Workstations of the Configuration Tool and use the Tools 
>Auto-Create Points option.  Navigate to the screen where the you want the few new points to be 
added and then create events on those points.  The Configuration Tool will auto-create them and 
place them in the upper left corner of the graphic display (multiples will be stacked in the upper left 
corner).  Then you can then position them over the background.

NOTE: The Workstation must be logged into before any of its settings can be configured.  A 
User that has the Security Option to configure settings needs to login to change an existing 
setting.  The factory defined User “Admin” has such a Security Option.  Information in this 
document is written assuming that a User with the equivalent Security Option of the “Admin” User 
will be performing the procedures in this document.
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Database Modifications Procedures ONYXWorks™ System Database Modification
3.2  Database Modifications Procedures
Use this procedure as guideline for creating and modifying a database.  It it is recommended that 
you use a Configuration PC because of how it is defined.  A Configuration PC is defined as a PC 
that has the Configuration Tool installed on it but is it not monitoring a life safety system.

Step I. Database Backup Creation Procedure
On the monitoring Workstation use one of the following procedures to create a copy of the 
database.

Create a Copy of Database on the Workstation with PC Monitor

In this procedure you will create a backup copy of the database and then copy it to an external 
storage device.

Step 1. Right click on the monitoring Workstation’s PC Monitor and then select Backup System 
Data...  The Browse For Folder window displays.

Step 2. Browse to a monitoring Workstation folder location and make a new folder (Create New 
Folder button) to copy the backup files to.

Step 3. Use Windows Explorer to copy the monitoring folders and files you created in Step 2 to an 
external storage device (USB flash-drive or CD-ROM).

Step 4. If necessary copy the folder and files to a read and write external storage device location.
Step 5. Start the Configuration Tool.  A Configuration Tool window displays.
Step 6. Select the Locate Database to Edit icon.  The Synchronize Data window displays.
Step 7. Click on the Browse button to locate and then open the *.mdb database file in its location.
Step 8. Click on the OK button.  An import window will temporary display and then the 

Configuration Tool main window will display.
Step 9. Perform the “Step II. Database Modification Procedure” on page 12.

Create Database On the Configuration PC with the Configuration Tool

In this procedure you will connect the Configuration PC to the same IP network as a Workstation 
and then import its database.

Step 1. Connect the Configuration PC to the IP network the monitoring Workstation IP network.
Step 2. Make the necessary IP settings to the Configuration PC.
Step 3. Start the Configuration Tool.  A Configuration Tool window displays.
Step 4. Select the Locate Database to Edit icon.  The Synchronize Data window displays.
Step 5. Select a Workstation IP address in the Select System to Import field.
Step 6. Click on the OK button.  An import window will temporary display and then the 

Configuration Tool main window will display.
Step 7. Perform the “Step II. Database Modification Procedure” on page 12.

NOTE: It is highly recommend you create a folder because the Backup System Data operation 
will create several folders and files, so grouping them in that one folder is desirable.
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ONYXWorks™ System Database Modification Database Modifications Procedures
Step II. Database Modification Procedure
In this procedure you will edit and then save the database.

Step 1. On the Configuration Tool main window click on the Screen Objects icon.  The Screen 
Object window displays.

Step 2. Edit the database (refer to the “Database Object Editing” on page 13 for information).
Step 3. Exit the Configuration Tool and then respond to the Save Changes prompt with a Yes 

button click to update the database.
Step 4. Perform the "Step III. Importing the Modified Database Procedure".

Step III. Importing the Modified Database Procedure
Use the applicable procedure to import your modified database back into the ONYXWorks™ 
system. 

Database Import from an External Device
Step 1. On the Configuration PC right click on its PC Monitor and select Backup System Data...  

The Browse For Folder window displays.
Step 2. Browse to a Configuration PC folder location and make a new folder (Create New Folder 

button) to copy the backup files to.
Step 3. Use Windows Explorer to copy the folder on the Configuration PC to an external storage 

device.
Step 4. Exit all the ONYXWorks™ system software applications that are running on the 

monitoring Workstation except PC Monitor.
Step 5. Right click on the monitoring Workstation’s PC Monitor icon and select Login.
Step 6. Select a User and type in their password (Admin = admin).
Step 7. Right click on the monitoring Workstation’s PC Monitor icon and then select Restore 

System Data... from the list of choices.  The Browse for Folder window displays.
Step 8. Use the Browse for Folder window’s browse capability to located the folder on the 

external storage device that contains the backup files and select it.
Step 9. Click on the OK button.  The edited files are installed on the monitoring Workstation.
Step 10. Restart monitoring Workstation and all of its relative the ONYXWorks™ system software 

applications.
Step 11. Verify your modified database displays correctly.
Step 12. You have completed "Database Modifications Procedures".

Database Import from a Configuration PC
Step 1. Connect the Configuration PC to the IP network the monitoring Workstation IP network.
Step 2. Start the Configuration PC’s version of the PC Monitor.
Step 3. Export/Import the Database.

• Right click on the PC Monitor icon and then select Export System Data to all 
Workstations from the list of choices.

• Use the monitoring Workstation’s version of PC Monitor to Import System Data 
operation (select the Configuration PC’s IP address). 

Step 4. Go to a monitoring Workstation and verify your modified database display correctly.
Step 5. You have completed "Database Modifications Procedures".
12 Configuration Tool Installation & Operation Manual - P/N: 53038:Rev: A  06/01/07



Database Object Editing ONYXWorks™ System Database Modification
3.3  Database Object Editing

3.3.1  Section Overview
Here is a list of the information in this section.

• “About the Edit Object Window” on page 14.
• “Screen Title and Background Additions Procedure” on page 15.
• “Navigation Icon Addition Procedure” on page 17.
• “Macro Button Addition Procedure” on page 18.
• “Macro Command Configuration” on page 19
• “Information Label Addition Procedure” on page 22.
• “Screen Additions and Point Icon Management Procedure” on page 23.
• “Point Icon Addition Procedure” on page 24.

NOTE: After completing any procedure in this section you can select Main Menu >Exit and you 
will be returned to the Configuration Tool main window.
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ONYXWorks™ System Database Modification Database Object Editing
3.3.2  About the Edit Object Window
The procedures in this section refer to the Configuration Tool’s Edit Object window areas as 
indicated in the figure.

Figure 3.1  Edit Objects Window

About Tools Menu

Autocreate Points

This function is accessed through the Tools menu on the Edit Objects window.  Select (checked) it 
when you are only be adding a few new devices to an already existing system. Here is the usage 
scenario:

1. You start the Configuration Tool.
2. You navigate to the screen where they want the point to locate on.
3. You check Autocreate Points
4. You work with others to create an off normal event in the point so it will report the event to the 

Workstation and the points icon will be added to screen.
5. Then you position the icon over the floor plan background.

This feature is not intended to be used for example, a loop with 300+ points, because it will place 
all the icons you add in the top left corner of the screen, stacked on top of each other.

Macro Editor

Refer to “Macro Command Configuration” on page 19 for information.

About the View Menu
This menu allows you to make a choice of whether to either Show Alias (names entered into Title 
and Caption fields) or Show Address (the point’s ID) for its respective icon in the Workstation floor 
plan area.

Graphics Additions to a Screen
The Configuration Tool includes a number of tools for creating vector-based graphics that will only 
can be reside on the screen that they are added to.  All of the tools are accessed through its 
respective tab on Edit Objects window.  These operations accessed through the icon menus are 
basically self explanatory and it is best they experimented with.  They operation associated to the 
tab’s icons can be identify by a mouse over...

Figure 3.2  Edit Objects Tabs

Main Menu

Navigation Tree

Workstation floor plan

Object tab icons that perform the same as 
Object >Add commands, mouse over to identify
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Database Object Editing ONYXWorks™ System Database Modification
3.3.3  Screen Title and Background Additions Procedure

Figure 3.3  Edit Objects Window

Step 1. On the Configuration Tool main window click on the Screen Objects icon.  The Edit 
Object window displays.

Step 2. Expand the Home plus sign in the Navigation Tree.
Step 3. Continue to expand the levels in the tree until you display a screen entry.
Step 4. Right click on the screen name and then select Properties from the list of choices.  The 

Screen Properties window displays.
Step 5. Type in a name for the screen in the Title field.
Step 6. Select a Background for the screen.

a. Click on the Select button in the Background area of the window.  An Open window 
displays.

b. Use the Open window to browse to and then double click on the file to use as floor 
plan background for the screen.  The background displays in the Background Preview 
area.

Step 7. Click on the OK button.  The Title displays in the Navigation Tree and the background 
displays in the Workstation floor plan area.
If you want to delete an existing background select the screen, right click on it for its 
properties, and then click on the Background Clear button.

Step 8. Repeat the steps in this procedure until you have named and added the backgrounds for 
the desired screens.  At this time it is recommend you do icon positioning and screen 
arranging, refer to "About Point Icons Locations and Screen Arrangement".

Step 9. You might now want to perform the “Navigation Icon Addition Procedure” on page 17.
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ONYXWorks™ System Database Modification Database Object Editing
About Point Icons Locations and Screen Arrangement
After you have named the screen and selected its background for the screen(s) created during the 
auto-creation process, you should position all the point icons in their correct position over the 
screen’s floor plan background.  In the Workstation floor plan area use a mouse drag and drop 
method to position the icon.  Repeat the drag and drop method for all point icons on the screen.

At anytime you can rearrange screens, making one screen a child of another screen, or promoting a 
child screen to a parent screen.  Any screen with a child screen is considered a parent screen, a 
parent screen can many child screens.

• You can use a drag and drop method.  This method is also used to modify child screens 
hierarchy below its parent screen.
Step 1. In the Navigation Tree click on and drag the screen.
Step 2. Release the mouse button when a line displays above the screen that the screen will be 

located below.  The Navigation Tree updates and the screen is displayed as a child of 
the parent screen.

Step 3. Repeat until the desire hierarchy is achieved.
• You can assign a screen a different parent using the Screen Properties.

Step 1. In the Navigation Tree right click on screen you want to make a child of another 
screen and then select Properties from the list of choices.  The Screen Properties 
window displays.

Step 2. In the Select Screen Parent tree select screen you want the screen to be a child of.
Step 3. Click on the OK button.  The Navigation Tree updates and the screen is displayed as a 

child of the parent screen.
Step 4. Repeat until the desire hierarchy is achieved.

Parent >Child Hierarchy Limitation  There are six levels that can be used.

NOTE: If you relocate a screen into an incorrect position in the Navigation Tree you must move 
it again (no undo command is available).

Home
    Screen level 1
        Screen level 2
            Screen level 3
                Screen level 4
                    Screen level 5
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Database Object Editing ONYXWorks™ System Database Modification
3.3.4  Navigation Icon Addition Procedure

Figure 3.4  Navigation Icon Window

Step 1. In the Navigation Tree select the screen from the alphabetical listing to add the Navigation 
Icon on.

Step 2. From the Edit Objects window’s main menu select Objects >Add >Navigation Icon.  The 
Navigation Icon window displays.

Step 3. Type in a caption for the Navigation Icon in the Caption field.
Step 4. Select a graphic to represent the Navigation Icon.

a. Click on the Select button in the Icon area of the window.  An Open window displays.
b. Use the Open window to browse to and then double click on the file to represent the 

Navigation Icon.  The icon displays in the icon preview area.
Step 5. Click on the OK button.  The typed caption and the icon display in the Workstation floor 

plan area.
Step 6. Repeat the steps in the procedure until you have added all of your desired icons.
Step 7. You might now want to perform the “Macro Button Addition Procedure” on page 18.
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ONYXWorks™ System Database Modification Database Object Editing
3.3.5  Macro Button Addition Procedure

Figure 3.5  Macro Button Window

Step 1. Create the macro command to execute so it will display in the Macro to Execute field 
(refer to “Macro Command Configuration” on page 19 for information).

Step 2. In the Navigation Tree select the screen to add the Macro Button on.
Step 3. From the Edit Objects window’s main menu select Objects >Add >Macro Button.  The 

Navigation Icon window displays.
Step 4. Type in a caption for the Macro Button in the Caption field.
Step 5. Select a graphic to represent the Macro Button.

a. Click on the Select button in the Icon area of the window.  An Open window displays.
b. Use the Open window to browse to and then double click on the file to represent the 

Macro Button.  The icon displays in the icon preview area.
Step 6. Click on the Macro to Execute fields down arrow and select a previously defined macro 

from the list of choices (refer to “Macro Command Configuration” on page 19 for 
information).

Step 7. Click on the OK button.  The typed caption and the icon display in the Workstation floor 
plan area.

Step 8. Repeat the steps in the procedure until you have added all of your desired icons.
Step 9. You might now want to perform the “Information Label Addition Procedure” on page 22.

NOTE: You should have created the macro command to execute before adding a Macro Button 
icon.  Refer to the “Macro Command Configuration” on page 19 about creating choices that will be 
displayed in the Macro to Execute field.
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Database Object Editing ONYXWorks™ System Database Modification
3.3.6  Macro Command Configuration

About Macro Commands

Macro commands have interdependent relationship that is established by the Admin User.  Macro 
Commands are created using the Configuration Tool which is launched from Workstation’s main 
menu; Configure >Launch Configuration Tool.  Any selection made here are saved when you exit 
the Configuration Tool and then respond to the Save Changes prompt with the applicable button 
click.

Macro are created and edited on the Screen Objects window (Screen Objects icon).  You access the 
Macro Editor function in Tools menu; Tools >Macro Editor.  A Macro command is created and 
defined, then it is activated in one of two ways.

• A macro icon may be created in the graphics display, when clicked on the associated macro 
will activate.

• The Workstation will display a Macros menu item when there are any configured macros on 
the system and a User logged in has the Security Option and Point Control.

The Admin User creates a Macro command by naming it and assigning it a Macro command.  That 
Macro command’s Menu list of choices will be contingent on the gateway type, point, and node 
type that is selected.

NOTE: Creating these settings is optional and they do not need to be made for the Workstation 
to function properly.

NOTE: Macros can only be edited at a Workstation when another Workstation is not editing 
them.
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ONYXWorks™ System Database Modification Database Object Editing
Macro Creation and Management
The Macro List and Macro Options areas have icons (with mouse over hints) that are used to create 
and or manage macros.  Mouse over them to display the hint about which operation each performs.

Figure 3.6  Macro Editor Window

Figure 3.7  Macro Properties Windows

Macro Creation Procedure
Step 1. Click on the Add Macro icon (mouse over).  The Macro Properties window displays.
Step 2. Type in a name in the Name field.
Step 3. Check the Confirmation field if applicable.

Step 4. Click on the OK button.
Step 5. Click on to add new option (mouse over) icon.  The Macro Option Properties window 

displays.
Step 6. Set up the Macro’s options

a. Select a Network.
b. Select a Node.
c. Select a Point.
d. Select an Action.
e. Click the OK button.

Step 7. Click on the Close button.

NOTE: This selection means a prompt will be displayed providing you the opportunity to cancel 
activating the macro.
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Database Object Editing ONYXWorks™ System Database Modification
Macro Button Creation Procedure

Macro Buttons are created using the Configuration Tool which is launched from Workstation’s 
main menu; Configure >Launch Configuration Tool.

Macro buttons are created and edited on the Screen Objects window (Screen Objects icon).  You 
access the Macro Button function in Objects menu; Add >Macro Button.  

Figure 3.8  Macro Button Window

Step 1. Type in the text you want displayed for the button in the Caption field.
Step 2. Select a Macro to Execute from the list of macro previously defined using the field’s down 

arrow.
Step 3. Chose an icon to use for the Macro button.

a. Click on the Select Icon button.  A Window Explorer window displays.
b. Select the icon from the Buttons folder.
c. Click on the Open button.  The icon displays in the Icon area.

Step 4. Click on the OK button to complete the entry.
Step 5. You must Exit the Configuration Tool and then respond to the Save Changes prompt with 

the applicable button click to update the Workstation with the information created in this 
procedure.
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3.3.7  Information Label Addition Procedure

Figure 3.9  Information Label Properties Window

Step 1. In the Navigation Tree select the screen to add the Information Label on.
Step 2. From the Edit Objects window’s main menu select Objects >Add >Information Label.  

The Information Label Properties window displays.
Step 3. Type in a caption for the Information Label in the Caption field.
Step 4. Select a graphic to represent the Information Label.

a. Click on the Select button in the Icon area of the window.  An Open window displays.
b. Use the Open window to browse to and then double click on the file to represent the 

Information Label.  The icon displays in the icon preview area.
Step 5. Select a Linked Media for the Information label (refer to "About Supported Linked Media 

Formats")
a. Click on the Browse button associated with the Linked Media type.  An Open window 

displays.
b. Use the Open window to browse to and then double click on the media type that is 

supported for the field.  The name of the file displays in the Linked Media field.
Step 6. Click on the OK button.  The typed caption and the selected icon display in the 

Workstation floor plan area.
Step 7. Repeat the steps in the procedure until you have added all of your desired icons.
Step 8. You might now want to perform the “Macro Button Addition Procedure” on page 18.

About Supported Linked Media Formats
When any of these file types are linked to a point they can be displayed or activated by selecting 
them from a point’s right click options menu.  Points with linked files are identified with an asterisk 
next to the point’s icon.  These are the types of files that can be used and their correspond to the 
field on the window.

• Text - *.txt or *.rtf file.
• Image - *.bmp, *.jpg, *.gif, or *.wmf file.
• Audio - *.wav file.
• Video - *.avi file.
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3.3.8  Screen Additions and Point Icon Management Procedure
You may want to add a screen.  For example the auto-creation process randomly added point icons 
to screens and since only 64 point icons can be added to one screen, your auto-creation process 
might have exceeded 64 points so it created another screen.  Therefore you may not have the screen 
hierarchy you desire and or the desired point groupings on those screens.

Figure 3.10  Screen Properties Window

Step 1. In the Navigation Tree select the screen you want to add the new screen below.
Step 2. From the Edit Objects window’s main menu select Objects >Add >Screen.  The Screen 

Properties window displays.
Step 3. Type in a name for the screen in the Title field.
Step 4. Select a Background for the screen.

a. Click on the Select button in the Background area of the window.  An Open window 
displays.

b. Use the Open window to browse to and then double click on the file to use as floor 
plan background for the screen.  The background displays in the Background Preview 
area.

Step 5. Click on the OK button.  The Title displays in the Navigation Tree and the background 
displays in the Workstation floor plan area.

Step 6. Select the screen that has the point icons that will be copied to it.
Step 7. Click on the point icon or press and hold the Ctrl key and select multiple icons.
Step 8. Right click on a point icon and select Cut from the list of choices.
Step 9. Right click on the screen that you paste the point icons onto and then select Paste from the 

list of choices.  The point icons display in the Workstation floor plan area.
Step 10. Position the point icon over the floor plan background.
Step 11. Repeat the steps until you achieve the desired point icon to screen locations.
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3.3.9  Point Icon Addition Procedure
You may want to add a point icon.  For example you have already modified the system database 
after the auto-creation process and you just want to manually add a new point icon to a specific 
screen using the Configuration Tool on a Workstation that is monitoring your ONYXWorks™ 
system.

Figure 3.11  Point Properties Window

Step 1. In the Navigation Tree select the screen you want to add the new point icon on.
Step 2. From the Edit Objects window’s main menu select Objects >Add >Point.  The Screen 

Properties window displays.
Step 3. Type in a name for the icon in the Point Alias field.
Step 4. Type in a description for the icon in the Point Description field.
Step 5. Click on the Network fields down arrow and select a previously defined network from the 

list of choices.  The Node field displays information.
Step 6. Click on the Node fields down arrow and select a previously defined Node from the list of 

choices.
Step 7. Type in the exact point ID in the Point field.
Step 8. Select whether to Autonavigate on the point if an off normal event occurs for it.
Step 9. Click on the Category fields down arrow and select a previously defined Category from 

the list of choices.
Step 10. Click on the Type fields down arrow and select a previously defined Type from the list of 

choices.
Step 11. Click on the OK button.  The Point Icon displays in the Navigation Tree and in the 

Workstation floor plan area.
Step 12. Repeat the steps until you added all the desired point icons.
24 Configuration Tool Installation & Operation Manual - P/N: 53038:Rev: A  06/01/07



Database Object Editing ONYXWorks™ System Database Modification
About a Point’s Icon and Linked Media Selection
A point’s icon, the image that represents it when it is displayed on the Workstation, can be changed 
using Configuration Tool functionality.  A point’s linked media, a file that can be automatically 
displayed or sounded for the point’s condition upon auto-navigation can be added too.  The 
flexibility in the Configuration Tool allows you to select a different icon for every condition of the 
point ((i.e. normal, alarm, pre-alarm, security, supervisory, trouble, disable, or other).  You can 
associate text, image, audio, video linked media files to the point’s individual condition too.  You 
need to display the conditions portion of the window by clicking on the arrow button adjacent to the 
Cancel button.

You can select one icon that will be displayed for all the point’s conditions.  When a condition is 
reported the same icon will display on the Workstation in the defined color for the condition (same 
icon, defined condition’s color).

You can vary the point’s icon for every condition.  When a condition is reported the varying icon 
will display on the Workstation in the defined color for the condition (different icon, defined 
condition’s color).

You can select link media files for each of the point’s conditions but you can only AutoActivate one 
linked media per condition (radio button) or None of them.  To set a point’s linked media to the 
same setting for all, use the Browse button for the applicable field and select a file, and then click 
on the Apply To All button.  The same linked media file will displays for all the conditions.  Then 
you can use the Up/Down arrows to scroll through the conditions and modify the usage of the 
AutoActivate selection.

Figure 3.12  Point Properties Icon and Media File Assignment

Point Icon Selection

C:\FacilitiesMonitoring\Data\Configuration Tool\System\Devices folder contains images files 
(used for devices such as detectors) and is the folder that displays when you click the Select Icon 
button.  The Clear button will remove the current icon usage.
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Point Linked Media Selection
Text Selection  C:\FacilitiesMonitoring\Data\Configuration Tool\System\Documents folder 
contains example text files and is the folder that displays when you click the Browse button 
adjacent to the radio button’s field.

Image Selection  C:\FacilitiesMonitoring\Data\Configuration Tool\System\Images folder 
contains images files (not used for devices such as detectors) and is the folder that displays when 
you click the Browse button adjacent to the radio button’s field.

Audio Selection  C:\FacilitiesMonitoring\Data\Configuration Tool\System\Sounds folder 
contains sound files and is the folder that displays when you click the Browse button adjacent to the 
radio button’s field.

Video Selection  C:\FacilitiesMonitoring\Data\Configuration Tool\System\Videos folder 
contains an example video file and is the folder that displays when you click the Browse button 
adjacent to the radio button’s field.
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Section 4 Configuration Tool Functions

4.1  Network Configuration
An Admin User you can use an automated method to establish a connection to your network if you 
are adding the Workstation to an existing ONYXWorks™ system.

4.1.1  About Adding an Existing Gateway 
When you first start the Workstation you can automatically connect gateways that are physically 
connected or available through your ONYXWorks™ system to the Workstation using PC Monitor 
operations.

Existing Network Connection Procedure
Step 1. Log into the Workstation (Admin = admin).
Step 2. Locate and right click on the PC Monitor icon in the Windows system tray and then select 

Import System Data... from the list of choices.  The Select System To Import From 
window displays.

Step 3. Select an entry from the list of choices and then click on the OK button.

Figure 4.1  Select System To Import From Window
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4.1.2  About Adding a New Network Connection
The Admin User creates a Network name and then adds a gateway.  Network Names and gateway 
connections are created using the Configuration Tool.  The Configuration Tool is launched from 
Workstation’s main menu.

New Network Connection Procedure
Step 1. Start the Workstation software application (Start >All Programs >Facilities Monitoring 

>Workstation).  The Workstation software applications starts.
Step 2. Login to the Workstation (Admin = admin).
Step 3. Launch the Configuration Tool from the Workstation’s Main Menu (select Configure 

>Launch Configuration Tool).  The Network Configuration window displays.
Step 4. Select Network >Add Network...  The Network Properties window displays.
Step 5. Type in the network’s name into the Alias field.
Step 6. Select the Type down arrow and select the type of network from the list of choices.
Step 7. Click on the Gateway Connection field’s Add Gateway icon (mouse over).  The Gateway 

Properties window displays.
Step 8. Add the gateway using one of the following:

• Type in the Gateway’s IP Address.
• Select a gateway from the list of Online Gateways.

The list of online gateways is filtered for the type of gateway selected in the Online 
Gateway field.  For example, if you are adding an NFN gateway, you would select 
NFN as the type, then only the addresses of NFN gateways running on the system will 
be display in the list.

Step 9. Request nodes to added to Network.
a. Expand the Navigation Tree to display the gateway’s IP address.
b. Right click on the IP address and then select Request Nodes from the list of choices.  

The tree will populate and display all the nodes configured on that network.
Step 10. Click on the OK button.
Step 11. You must Exit the Configuration Tool and then respond to the Save Changes prompt with 

the applicable button click to update the Workstation with the information created in this 
procedure.
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Network Right Click Commands
In the Navigation Tree you can right click on a Network name and select these commands from the 
list of choices.

Add Node

Use this command to add a Node to your network.  You will need to select the Node Type from a 
list of choices and type in the IP address of that node. 

Import Database

Use this command to import a Verifire database.  A Verifire database can located and then selected, 
any nodes and points in that are in the database will be auto-created on the Network.

Rename

Use a operation to type in a new name for the Network which is the equivalent of replacing the 
Network Alias on the Properties window.

Delete

Use this command to delete the Network, a confirmation prompt will display allowing you to 
cancel the command.

Properties

Use to add a redundant gateway to the Network, adding two gateways to one Network will sets up 
gateway redundancy.  You can also change the Network Alias name on this Network Properties 
window.
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4.2  System Options Configuration

4.2.1  Icon Set
Icon Set Selection
Step 1. Check the Update Icons checkbox to activate the Icon Set field.
Step 2. Click on the Icon Set field’s down arrow to display a list of icon choices.
Step 3. Click on the OK button.
Step 4. You must Exit the Configuration Tool and then respond to the Save Changes prompt with 

the applicable button click to update the Workstation with the information created in this 
procedure.

Custom Icon Creation and Selection
If you create and then load a custom icon set and it is missing required icons (i.e. smoke detector) 
then the points that require that type of icon will not be displayed.  To avoid this undesirable 
behavior do the following.

Step 1. Create your custom icons with your graphic software application (256 x 256 PNG file 
formats highly recommended).

Step 2. Auto-create your points on the Workstation (refer to “Auto-Create Gateway Point IDs” on 
page 37).

Step 3. Copy and paste your custom icons into the appropriate 
C:\FacilitiesMonitoring\Data\System folder on the Workstation:
Devices - for auto-created points
Buttons - for Macro Buttons
Images - for hazard, information icons, etc.

Step 4. Launch the Configuration Tool and then edit the data base (refer to “Workstation Database 
Modifications” on page 38).
• Use the Configuration Tool’s Point Properties to modify the point’s icon.  Refer to 

Configuration Tool manual for more information.
• Use the Configuration Tool’s spread sheet operation:

• Find and select the existing icon that will be replaced by your custom icon.
• Use the spread sheet’s Explorer function to locate and then select the custom icon 

from the folder you pasted it into.
• Replace one of the existing icon names with the custom icon name.
• Copy the spread sheet cell and copy and paste it into the cells containing the name 

of the existing icon.
• Save the spread sheet and close the window.

Step 5. You must Exit the Configuration Tool and then respond to the Save Changes prompt with 
the applicable button click to update the Workstation with the information created in this 
procedure.

NOTE: All Workstations have a System Options selection preset according the type of 
Workstation ordered.

NOTE: The previously selected Icon Set does not display in the Icon Set field.  The default 
IconSet3D displayed as grayed out.
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4.2.2  Operating Modes

Supervising Station

This operation is considered to be relevant to Workstation operation so you should refer to the 
Workstation manual.

FCC and FCC+DCC

This operation is considered to be relevant to Workstation operation so you should refer to the 
Workstation manual.

NOTE: The Workstation mode and the a NFN gateway must be set to the same mode.

NOTE: You can only select the FCC and FCC+DCC modes if you only have one NFN gateway 
connected to the Workstation.  Those modes are not available with multiple NFN gateways or if 
any other type of gateway is configured for your system.
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4.2.3  Time Server Settings

This field is used to type in the IP address of the server that will used to dictate time for the 
ONYXWorks™ system time.

Figure 4.2  System Options Window

4.3  Screen Objects
Refer to “Database Object Editing” on page 13 for information.

NOTE: If the Workstation’s Windows time zones or daylight saving settings are changed, all the 
ONYXWorks™ applications must be restarted.
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4.4  Color and Sound Configuration

Custom colors and custom sounds for different event types are created using the Configuration 
Tool.

4.4.1  About Color Configuration Settings
The color configuration function allows the point icons, alarm summary icons, and alarm indicator 
in the navigation to display custom colors on all Workstation in the system not just the Workstation 
where the color change was defined.  Each event type may have a custom color assigned to it.  The 
Workstation will display that color on the point icon, alarm summary icon, and the alarm indicator 
on the left of the navigation tree.

New Color for an Event Type Selection
Step 1. Double-click on the colored rectangle next to the event type.  The Color window displays.
Step 2. Click one of the pre-defined basic colors or click the Define Custom Colors button to 

select a customized color.
Step 3. Click OK when all colors choices have been made.
Step 4. Click the Save button on the Color and Sound Configuration window to update the 

Workstation with the new colors
Step 5. You must Exit the Configuration Tool and then respond to the Save Changes prompt with 

the applicable button click to update the Workstation with the information created in this 
procedure.

Figure 4.3  Color Configuration

NOTE: Making these settings is optional and they do not need to be made for the Workstation to 
function properly.

NOTE: Multiple Workstation systems will require a color change be made to each Workstation if 
the desired color change is needed for every Workstation.

NOTE: To fully update the Workstation with the new color configuration, the Workstation software 
application must be exited and then restarted.
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4.4.2  About Sound Configuration Settings
Each event type may be configured to play a different sound.  For example a fire alarm sound may 
be configured so that it is distinctly different from the sound of a trouble event.  The Color and 
Sound Configuration tab displays the currently configured sound in the Wave File window.

Sound Changes

Step 1. Click the inside the Wave File field  An Open window will display.
Step 2. Select the desired wave file and click the Open button.  The name of the newly selected 

file will be displayed in the Wave File window.
Step 3. Click the Save button to update the Workstation software with the new sounds.

Figure 4.4  Choosing a Sound File

4.5  Launch Spread Sheet Editor
This enhanced graphical setup functionality is used to create an Excel like database format when 
importing an existing VERI-FIRE databases (Veri-Fire 1020, Veri-TCD, Verifire etc.).

Figure 4.5  Database Editor Window

The Excel like database is to view and modify system database information.  It has standard editing 
features, such as Copy, Paste, Select, Find, Cut, Delete, etc.

The Point tab’s columns are reveal by using the bottom side scroll.  Those columns support adding 
and modifying:

• Icon usage for the point.
• Links to Text, Wave File, Picture, and Video formats for the point.

NOTE: Factory default sounds are assigned so that a different sound will play for each status. 
They may be changed if desired.

NOTE: To able to define a sound for an event; a sound file in a *.wav format must be placed into 
the Workstation’s ... \Applications\Configuration Tool\Sounds folder.
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Limited Warranty
Honeywell International Inc. warrants products manufactured by
it to be free from defects in materials and workmanship for
eighteen (18) months from the date of manufacture, under normal
use and service.  Products are date stamped at time of
manufacture.  The sole and exclusive obligation of Honeywell
International Inc. is to repair or replace, at its option, free of charge
for parts and labor, any part that is defective in materials or
workmanship under normal use and service.  All returns for credit
are subject to inspection and testing at the factory before actual
determination is made to allow credit.  Honeywell International
Inc. does not warrant products not manufactured by it, but assigns
to the purchaser any warranty extended by the manufacturer of
such products. This warranty is void if the product is altered or
repaired by anyone other than Honeywell International Inc. or as
expressly authorized by Honeywell International Inc. in writing, or
is serviced by anyone other than Honeywell International Inc. or
its authorized distributors. This warranty is also void if there is a
failure to maintain the products and systems in which they operate
in a proper and workable manner.  In case of defect, secure a
Return Material Authorization form from our Return Authorization
Department.

This writing constitutes the only warranty made by Honeywell
International Inc., with respect to its products.  Honeywell
International Inc., does not represent that its products will prevent
any loss by fire or otherwise, or that its products will in all cases
provide the protection for which they are installed or intended.
Buyer acknowledges that Honeywell International Inc., is not an
insurer and assumes no risk for loss or damages or the cost of any
inconvenience, transportation damage, misuse, abuse, accident or
similar incident.

HONEYWELL INTERNATIONAL INC. GIVES NO WARRANTY,
EXPRESS OR IMPLIED, OF MERCHANTABILITY, FITNESS FOR
ANY PARTICULAR PURPOSE, OR OTHERWISE WHICH
EXTENDS BEYOND THE DESCRIPTION ON THE FACE
HEREOF.  UNDER NO CIRCUMSTANCES SHALL HONEYWELL
INTERNATIONAL INC.  BE LIABLE FOR ANY LOSS OF OR
DAMAGE TO PROPERTY, DIRECT, INCIDENTAL OR
CONSEQUENTIAL, ARISING OUT OF THE USE OF, OR
INABILITY TO USE HONEYWELL INTERNATIONAL INC.’S
PRODUCTS.  FURTHERMORE, HONEYWELL INTERNATIONAL
INC. SHALL NOT BE LIABLE FOR ANY PERSONAL INJURY OR
DEATH WHICH MAY ARISE IN THE COURSE OF, OR AS A
RESULT OF, PERSONAL, COMMERCIAL OR INDUSTRIAL USE
OF ITS PRODUCTS.
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